Actualité iPhone / iPad
vignette tiny umbrella 0090005200014367 0090005200014912

TinyUmbrella s'offre une nouvelle mise à jour

par
Source: TinyUmbrella

Le logiciel permettant la sauvegarde des certificats SHSH en local s'offre une mise à jour, il supporte désormais l'iPhone 4S.

C'est devenu une habitude chez semaphore, développeur du logiciel TinyUmbrella, a chaque fois qu'Apple sort un nouveau firmware, il a pris l'habitude de mettre son logiciel à jour. En effet TinyUmbrella,  passe en version 5.01.00. Nous vous rappelons que TinyUmbrella permet de sauvegarder vos SHSH en local ainsi que sur les serveurs de Saurik. Une fois enregistrés, vous pourrez downgrader vos appareils vers tous les firmwares dont vous possédez les certificats.

Dans cette nouvelle version, en plus de prendre en charge l'iOS 5.0.1 et de le sauvegarder, il devient maintenant compatible avec l'iPhone 4S. Sans eux, vous ne pouvez pas downgrader vos appareils, car si vous lancez une restauration avec un firmware non validé, iTunes vous affichera une belle erreur 3194.  

banniere-tiny-umbrella_02EC000000014368
Depuis la version 5.00.07, il est possible de choisir l'option « Update iPhone 4 BaseBand » qui permet de conserver le BaseBand de son appareil pour un futur désimlockage via Ultrasn0w. Attention, si vous passez en 5.0.1 sachez que vous ne devriez plus pouvoir downgrader même si vos certificats SHSH sont sauvés. En effet, Apple a récemment ajouté une sécurité à l'iOS qui vérifie la signature du firmware (grâce à un code unique délivré à l'appareil lors de la restauration) et empêche la restauration vers un firmware qui n'est plus signé. Sachez tout de même que les hackeurs travaillent dessus pour contourner ce problème.


Commenter 6 commentaires

DarkCenobyte
Mon iPhone 4S est en 5.0 et ça fonctionne.

Enfaite, TinyUmbrella se moque de la version de notre appareil, ce qui importe, c'est l'ECID de l'appareil.

Ensuite, TinyUmbrella peux récupérer le SHSH du moment qu'il existe sur Cydia ou est encore "signé" par Apple.
Donc pour un 4S la seule possibilité est d'avoir le SHSH pour le 5.0.1 , mais ceci reste possible MÊME avec un appareil seulement en 5.0 .

Sinon, il semble qu'il y est un bug avec le serveur de Cydia (tout du moins si on demande le SHSH d'un iPhone 4S), j'ai du décoché la case demandant de passer par le serveur Cydia dans l'onglet avancé (et donc TinyUmbrella à fait la requête du SHSH directement du coté d'Apple), et ça à marcher.
Signaler Citer
thomas_
hello,

pour ma part, ca ne fonctionnait pas ni pour mon 4s, ni celui de ma femme, tout deux en 5.0

la petite astuce:
tu telecharges usbview
tu passes ton iphone en dfu
et dans les caracteristiques dans usbview tu peux recuperer ton ecid

ensuite dans tinyumbrella tu n as plus qu a creer manuellement ton iphone (manual ecid) en specifiant l ecid, lui donnant un nom et precisant qu il s agit d un 4S

tu decoches request shsh from cydia dans l ongle advanced

tu n as plus qu a cliquer sur l iphone que tu as créé et qui doit apparaitre dans custom devices puis cliquer sur save shsh

that's all

tiny va recuperer ton shsh du 5.0.1 sur les serveurs d apple
Signaler Citer
simon545
DarkCenobyte a écrit:

Sinon, il semble qu'il y est un bug avec le serveur de Cydia (tout du moins si on demande le SHSH d'un iPhone 4S), j'ai du décoché la case demandant de passer par le serveur Cydia dans l'onglet avancé (et donc TinyUmbrella à fait la requête du SHSH directement du coté d'Apple), et ça à marcher.


C'est normal que ça marche pas avec Cydia, ton 4S n'a jamais été jailbreaké, comment veux tu qu'il le retrouve sur les serveurs de Cydia ?

Les serveurs de Cydia marchent très bien actuellement ;)
Signaler Citer
corgato
Bonjour,

je voulais savoir si on pouvait quand même downgrader si on a une ancienne sauvegarde faite avec iFaith ou si c'est vraiment plus possible pour l'instant de donwgrader si on est passé sous IOS 5 ?

Mon iPhone est JB et je dois aussi décocher la case pour qu'il télécharge le SHSH, mais il ne se situe pas sur cydia par contre (En haut de cydia j'ai tout sauf celle de l'iOS 5 et 5.0.1).

Merci pour la news !
Signaler Citer