Actualité iPhone / iPad
news

Apple fait plier Skype sur l'AppStore

par

Alors qu'une première version de Skype pour iPhone est sortie le 31 mars 2009 sur l'AppStore, voici une mise à jour qui va en surprendre plus d'un d'entre vous.

Merci à Mattlinux

Alors qu'une première version de Skype pour iPhone est sortie le 31 mars 2009 sur l'AppStore (voir notre précédente news à ce sujet ICI), voici une mise à jour qui va en surprendre plus d'un d'entre vous.

Cela avait déjà été un évènement sur l'AppStore si farouchement gardée par Apple et tellement politiquement correcte, la sortie d'une version Skype pour iPhone a fait beaucoup de bruit il y a quelques mois. Les opérateurs de téléphonie, déjà échaudés par les possibilités offertes par le jailbreak, avaient fait tout leur possible pour bloquer l'arrivée du roi de la VoIP sur iPhone.



Il était finalement apparu sur le Store, mais avec quelques limitations dont bien évidemment l'impossibilité de pouvoir passer des appels VoIP en 3G, ainsi que la détection d'une version jailbreakée de votre firmware 2.2.1 (voir la news sur ce sujet ICI).



Avec le nouvel OS 3.0, voici la nouvelle mise à jour de Skype mais toujours avec les mêmes limitations :



Cette version vous empêche toujours de pouvoir passer des appels en 3G et continue de vérifier si votre iPhone est jailbreaké et le cas échéant refuser de se lancer !

Pourquoi une telle limitation ?

Assurément elle n'est pas du fait de Skype, qui se fiche pas mal de savoir quelle version jailbreakée ou non d'OS vous faites tourner sur votre iPhone, mais on sent bien là une nouvelle fois la pression des opérateurs.
Pour autoriser Skype à continuer à être présent sur l'AppStore, Apple a du négocier fermement l'ajout d'un module de détection de l'OS au démarrage de l'application sous la pression des opérateurs, surtout depuis qu'un simple module Cydia permettait de faire sauter cette limitation qui n'avait en fin de compte absolument rien de technique (voir notre news ICI).

Si vous pouvez passer vos appels en VoIP à un tarif ultra concurrentiel par rapport au coût à la minute que vous facture votre opérateur et qu'en plus cela est rendu facile grâce aux nouveaux forfaits avec internet illimité, on imagine bien que les opérateurs font la tête et ne voient pas d'un bon oeil l'arrivée de cet opérateur virtuel qui s'appuie malgré eux sur leur infrastructure de réseau. Ils ont donc réussi à faire suffisamment pression sur Apple pour que l'entrée de Skype sur l'AppStore soit conditionné par la détection d'un OS jailbreaké.

Reste à savoir si la Dev-Team serait capable d'outrepasser cette détection, puisque comme vous le savez, dans ce genre de bridages, c'est un éternel jeu du chat et de la souris...

Wait & See !



Mots-clés

Commenter 15 commentaires

Anonymous
Bonjour,
Skype tourne parfaitement sur mon iphone 3g jailbreak et meme en 3g... pourtant je suis en 3.0 et c'été pareil pour la première version.
Une explication?
Signaler Citer
hichbg
Pour ma part, après la mise a jour de la version précédente en 2.2.1, j'avais dut installer skype de façon détournée....(pas très légale en fait!!!)
Tout a l'heure en me connectant a l'AppStore et en voyant qu'il y avait une nouvelle mise a jour, j'ai vite fait d'aller voire ailleurs......y a pas moyen que j'installe une nouvelle version m'empêchant l'utilisation en 3G.....


Edit JeToO: LE WAREZ EST INTERDIT. Merci de ne pas y faire allusion.
Signaler Citer
Anonymous
Je vien de faire la derniere mise a jour directement de l'appstore donc pas une version patcher ni rien et la je suis sur skype par la 3G sur un iphone3g jailbreak...
Signaler Citer
Avatar de l’utilisateur
Rob
Personnellement c'est 100% opérationnel sur jailbroken 3.0 et avec la précédente version de Skype. Je ne tenterai pas la pomme en essayant avec la nouvelle version.
Signaler Citer
Mattlinux
Apparament on peut quand même l'utiliser... J'en ai fait les frais, mais elle crache souvent, c'est vraiment bizare ce message...
Déjà avant cette mise à jour, il y avait un message (si on était en 3.0) disant que la version ne fonctionnait qu'avec le 2.2.1 mais bizarrement sa fonctionnait aussi...
Donc je sais pas ce qu'il fout la ce message mais bon...
Peut-être qu'Apple recense les iPhone jailbreakés...
Signaler Citer