Actualité iPhone / iPad
ios 7 logo

App Store : l'optimisation iOS 7 obligatoire pour les développeurs dès le début d'année 2014

par
Source: Apple

Apple demande aux développeurs de se mettre à jour.

Dans une note de service adressée aux développeurs, Apple a insisté sur le fait que les applications soumises sur l'App Store se doivent désormais d'être optimisées pour la dernière version du système, à savoir iOS 7.

En effet, la marque à la pomme précise que pour qu'une application soit validée à partir du 1er février 2014, elle devra être conçue avec la dernière version de Xcode 5, API de développement fournie par la firme et optimisée pour iOS 7, ce afin d'uniformiser les différents logiciels disponibles sur les iPhone, iPod touch et iPad et offrir une meilleure expérience aux consommateurs. Notons que cela concerne non seulement les nouvelles applications, mais également les mises à jour.

Afin d'aider les développeurs dans leur tâche, un guide a été mis en ligne pour proposer des designs proches de l'expérience native d'iOS 7.

À partir de février, les développeurs devront donc s'aligner, qu'ils le souhaitent ou non, s'ils veulent continuer de voir leur travail publié sur l'App Store. Il est vrai qu'avec plus de 74 % d'adoption du système sur iPhone et près de 64 % pour les iPad d'après Chitika, ils ont tout intérêt à s'adapter...

ios-7-logo

Commenter 7 commentaires

Avatar de l’utilisateur
dark2naruto
Apple veut forcer le consommateur à passer sous IOS7 ?? Je le vois limite comme cela, et sûrement pour essayer de gagner encore quelques abandons de la part des utilisateurs d'IOS6... qui sont majoritairement (tout comme moi) des utilisateurs d'iDevices JB !
Signaler Citer
Avatar de l’utilisateur
FCSKZBC
Est ce que ça veut dire que tous les prochains jeux ne seront compatibles qu'avec iOS 7 ou supérieur?

Si c'est ça, tant pis, je craque: j'ai acheté mon touch 4G 64 Go à 400 euros environ il y a moins de deux ans, il fonctionne encore très bien mais les prochains jeux ne fonctionneront plus dessus? Un coup de Jailbreak et à moi les jeux gratuits...
Je vais pas aller débourser 450 pour le nouveau et en changer à chaque génération!
Pour les nouveaux jeux, j'ai mon S3, mais là, je ne sais pas avoir de crédit, donc je suis obligé de télécharger illégalement.

Je suis tout à fait pour soutenir les développeurs, mais quand on pousse l'obsolescence programmée à ces extrêmes, tant pis, aucune pitié
Signaler Citer
Avatar de l’utilisateur
xXKevinxX
LordGuard a écrit:Obsolescence programmée... Apple pousse à la consommation par des changements réguliers afin que les iDevices deviennent incompatibles avec les nouveaux jeux et programmes :x pour ne pas changer


Si c'était que ça.. Sur mon iPhone 4 avant que j'installe l'iOS 7 tout fonctionnait parfaitement, maintenant, des messages ne s'écrivent pas, il freeze, le dévérouillage se fait très mal.. L'écran tactile est limite en retard par rapport à ce que j'écris.. Bref, ils me pousse à racheter un iPhone 5 pour qu'il soit optimisé pour l'iOS 7 mais ils peuvent bien rêver, plus jamais je retourne chez Apple, des vrais arnaqueurs ! :roll:

FCSKZBC

Il existe un moyen de contourner la limitation logicielle en utilisant le hack :lol:
Signaler Citer
Avatar de l’utilisateur
FCSKZBC
xXKevinxX a écrit:Il existe un moyen de contourner la limitation logicielle en utilisant le hack :lol:


Que veux tu dire? Pour installer iOS 7 ou pour installer des jeux normalement pas compatibles?

D'après ce que j'ai compris, la puce graphique a fortement changé entre ipod touch 4G et 5G, le problème d'incompatibilité n'est pas dû qu'à l'OS, mais aussi du matériel qui est un peu différent.

Donc, les développeurs, que font ils? Ils développent leurs nouvelles applications avec les derniers outils, sauf que ces derniers outils ne sont pas compatibles avec les "anciens appareils", donc ils devraient développer 2X l'application...
Signaler Citer
Avatar de l’utilisateur
xXKevinxX
Tu n'as qu'à modifier à l'aide d'un logiciel sur ton pc l'application en l'ouvrant avec Winrar, il suffit de modifier une ligne ou il met iOS minimum version et tu change en 5.1.1 par exemple, ainsi, tu sais installer et jouer aux jeux nécessitant l'IOS 6.
Signaler Citer
Avatar de l’utilisateur
FCSKZBC
Je crois pas que ce soit aussi simple que ça.
J'ai parlé avec un développeur car j'étais déçu que son jeu ne soit pas compatible avec mon ipod et apparemment, les nouvelles générations d'appareils sont très différents des anciennes. Il aurait fallu reprogrammer toute l'application pour que ça fonctionne et pas juste changer une ligne.

D'ailleurs, si c'était aussi facile, pourquoi est-ce que les développeurs ne le font pas à l'origine? Leurs applications seraient compatibles avec un plus grand nombre d'appareils, augmentant ainsi le nombre potentiel de ventes
Signaler Citer